Follow

oh good, maps.me now requires Android 5+

(which I don't have)

ye olde maps open app recommendations anyone? (Android 4.2.2)

rhiaro.co.uk/2020/10/oh-good-m

@rhiaro I remember rooting my phone at some point when google mail stopped working on my 2.3.5 because it was "insecure" lol

@rhiaro I'm still using OSMAnd from FDroid. It's slow to start up but works on 4.2.2

@priryo yep I'm trying this one, it seems a bit laggy but overall pretty good so far. Thanks!

@twsh yep I'm trying this one, it seems a bit laggy but overall pretty good so far

@rhiaro You could try some of these map apps?
wiki.p2pfoundation.net/Free_Co

The table doesn't have minimum versions though, sorry. +1 for OSMand+ being great, works for me on Android 4.4.4.

@strypey yep I'm trying this one, it seems a bit laggy but overall pretty good so far. Thanks!

Sign in to participate in the conversation
Toot.Cat

The social network of the future: No ads, no corporate surveillance, ethical design, and decentralization! Own your data with Mastodon!